Start a new topic

Right hand

Hi have a prob with right hand crank. Not reading power getting a very low reading! Left is fine . What should we do new battery's ?? Cheers

2 people have this question

I am having the same problem. In less than 9 months, 100 hours riding, my right crank batteries are empty for the second time!!! And I have bought good batteries. The left side are still working fine. What can I do?

Same thing is happening to me. These cranks are a nightmare. I brought them cause they were meant to be easy....

My crank is brand new and the drive side isn't being picked up, any of you had the issue resolved?


1 person likes this

I'm having the same problem.  My infocrank is only a few months old and I have never gotten it to capture the right crank torque/power data.  My ENTIRE reason for buying the Infocrank was to measure power on BOTH legs.  If Verve can't get this to work, then I want a refund and will go with a much cheaper option.

Installing the new infocrank for the first time (without cadence magnets) and it won't pick up the right side sensor.  Does anyone know the reason for this or how to fix it?

Having the same issue brand new crank not picking the right side up on installation. New batteries etc. This is the second crank in the family first is spot on
In the end I was lucky enough to have one of the guys from Verve on the phone walking me through the troubleshooting steps and it has worked perfectly ever since.
Alan Can you remember what was done to resolve it ?
I can’t I’m sorry because there were just so many steps that had to be performed in a very specific order
Login or Signup to post a comment